diff setup.py @ 799:0b56b1492d23

Fix setup.py calls to hg.bat on Windows
author Patrick Mezard <pmezard@gmail.com>
date Sat, 16 Apr 2011 17:46:38 +0200
parents 3bffdf0e5948
children 076ded084655
line wrap: on
line diff
--- a/setup.py
+++ b/setup.py
@@ -18,7 +18,8 @@ except ImportError:
     from distutils.core import setup
 
 def runcmd(cmd, env):
-    p = subprocess.Popen(cmd, stdout=subprocess.PIPE,
+    shell = os.name == 'nt'
+    p = subprocess.Popen(cmd, stdout=subprocess.PIPE, shell=shell,
                          stderr=subprocess.PIPE, env=env)
     out, err = p.communicate()
     # If root is executing setup.py, but the repository is owned by