diff setup.py @ 681:26b85c0cf48a

setup: require Subvertpy when the SWIG bindings are unavailable. This isn't quite good enough if the Subversion installation is too old, but we'd have to replicate the actual version check to deal with that.
author Dan Villiom Podlaski Christiansen <danchr@gmail.com>
date Wed, 11 Aug 2010 19:57:35 +0200
parents 55d6697b975a
children 050f03a3bdf5
line wrap: on
line diff
--- a/setup.py
+++ b/setup.py
@@ -99,9 +99,11 @@ try:
 except ImportError:
     requires.append('mercurial')
 
-# Ensure that the Subversion bindings are present
-sys.path.insert(0, 'hgsubversion')
-import svnwrap
+# If the Subversion SWIG bindings aren't present, require Subvertpy
+try:
+    from hgsubversion.svnwrap import svn_swig_wrapper
+except ImportError:
+    requires.append('subvertpy>=0.7.3')
 
 setup(
     name = 'hgsubversion',