2009-06-15 |
Augie Fackler |
tests: fix for new branch heads change in upstream hg.
|
2009-06-15 |
Augie Fackler |
stupid: handle the new eol option in hg-crew.
|
2009-06-12 |
Dirkjan Ochtman |
put convert_revision in branch-closing csets
|
2009-06-12 |
Dirkjan Ochtman |
svnmeta: move util.build_extra() to SVNMeta.genextra()
|
2009-06-11 |
Dirkjan Ochtman |
editor: rename hg_delta_editor.HgChangeReceiver to editor.HgEditor
|
2009-06-11 |
Dirkjan Ochtman |
svnmeta: eliminate unneeded path_and_branch_for_path() method
|
2009-06-11 |
Dirkjan Ochtman |
imported patch import-cleanup
|
2009-06-11 |
Dirkjan Ochtman |
save metadata from one place
|
2009-06-11 |
Dirkjan Ochtman |
svnmeta: deprivatize a bunch of member functions
|
2009-06-11 |
Dirkjan Ochtman |
invert the svnmeta/editor relationship
|
2009-06-11 |
Dirkjan Ochtman |
svnmeta: move revmap methods, make last_known_revision() more efficient
|
2009-06-11 |
Dirkjan Ochtman |
split parts of HgChangeReceiver out into an SVNMeta class
|
2009-06-11 |
Dirkjan Ochtman |
sort HgChangeReceiver methods and properties
|
2009-06-10 |
Dirkjan Ochtman |
stupid: eliminate dependency on editor.current
|
2009-06-11 |
Dirkjan Ochtman |
editor: move current revision state into a separate class
|
2009-06-10 |
Dirkjan Ochtman |
move aresamefiles() from HgChangeReceiver to util
|
2009-06-11 |
Dirkjan Ochtman |
extract the filemap support into a separate class
|
2009-06-10 |
Dirkjan Ochtman |
extract the revmap support into a separate dict-like class
|
2009-06-10 |
Dirkjan Ochtman |
editor: use decorators, get rid of unnecessary property
|
2009-06-10 |
Dirkjan Ochtman |
add a function to generate svn_commit_hashes
|
2009-06-10 |
Dirkjan Ochtman |
editor: simplify HgChangeReceiver constructor signature
|
2009-06-10 |
Dirkjan Ochtman |
add a working incoming wrapper command
|
2009-06-10 |
Dirkjan Ochtman |
uisetup: use a single loop/abstraction for wrapping all the commands
|
2009-06-10 |
Dirkjan Ochtman |
uisetup: move clone and push/pull wrappers to wrappers module
|